Notifications by email

Somehow I still get emails with notifications after unchecking the box at the settings.

Does anyone know how to fix this? I do not need te be spammed by mails while working. .
 
I might have missed that one :oops: I will try that box ;)

Edit: somehow I completely missed the menu in which this option was. But yaay, no more notifications :D
 
Bump! I am working tomorrow and don't want to be destracted by emails from the forum, I need to work instead of counting and spamming the forum ;)
 
Thank you Miss M. Ennasil PM me a screen of your browser preferences for the forum or send in a ticket with that screenshot. If you saved the changes that Miss M pointed out, you should not be receiving email notifications.